On Thu, 10 Apr 2025 17:39:39 +0200
Jean-Baptiste Maneyrol via B4 Relay <devnull+jean-baptiste.maneyrol.tdk.com@kernel.org> wrote:
> The purpose of this series is to switch to fwnode_irq_get_by_name()
> in the core module instead of using irq from the bus parsing.
>
> Add in dt binding interrupt naming and up to 2 interrupts support.
>
> Signed-off-by: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@tdk.com>
Applied to the togreg branch of iio.git. Initially pushing that out as
testing for 0-day to poke at it.
Thanks,
Jonathan
> ---
> Changes in v4:
> - Change dt-binding commit message to be more explicit about interrupt
> support.
> - Simplify fwnode usage, NULL checking is already done automatically.
> - Link to v3: https://lore.kernel.org/r/20250409-iio-imu-inv-icm42600-rework-interrupt-using-names-v3-0-dab85a0a7c2b@tdk.com
>
> Changes in v3:
> - Update dt-binding to report support of the 2 interrupts and delete
> remark about driver feature support.
> - Link to v2: https://lore.kernel.org/r/20250407-iio-imu-inv-icm42600-rework-interrupt-using-names-v2-0-c278acf587b2@tdk.com
>
> Changes in v2:
> - Add INT2 in interrupt-names enum and fix enum
> - Add fallback to first interrupt if naming is not here to ensure
> backward compatibility
> - Link to v1: https://lore.kernel.org/r/20250404-iio-imu-inv-icm42600-rework-interrupt-using-names-v1-0-72ed5100da14@tdk.com
>
> ---
> Jean-Baptiste Maneyrol (2):
> dt-bindings: iio: imu: icm42600: add interrupt naming support
> iio: imu: inv_icm42600: switch to use generic name irq get
>
> .../devicetree/bindings/iio/imu/invensense,icm42600.yaml | 13 ++++++++++++-
> drivers/iio/imu/inv_icm42600/inv_icm42600.h | 2 +-
> drivers/iio/imu/inv_icm42600/inv_icm42600_core.c | 14 ++++++++++++--
> drivers/iio/imu/inv_icm42600/inv_icm42600_i2c.c | 2 +-
> drivers/iio/imu/inv_icm42600/inv_icm42600_spi.c | 2 +-
> 5 files changed, 27 insertions(+), 6 deletions(-)
> ---
> base-commit: 1c2409fe38d5c19015d69851d15ba543d1911932
> change-id: 20250325-iio-imu-inv-icm42600-rework-interrupt-using-names-b397ced72835
>
> Best regards,