[PATCH 11/34] defconfigs: rename CONFIG_MFD_SEC_CORE to CONFIG_MFD_SEC_I2C

André Draszik posted 34 patches 1 month, 2 weeks ago
There is a newer version of this series
[PATCH 11/34] defconfigs: rename CONFIG_MFD_SEC_CORE to CONFIG_MFD_SEC_I2C
Posted by André Draszik 1 month, 2 weeks ago
We are adding support for Samsung PMICs that aren't using I2C and
therefore had to rename the Kconfig symbol.

Signed-off-by: André Draszik <andre.draszik@linaro.org>
---
 arch/arm/configs/exynos_defconfig   | 2 +-
 arch/arm/configs/multi_v7_defconfig | 2 +-
 arch/arm/configs/pxa_defconfig      | 2 +-
 arch/arm64/configs/defconfig        | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/arm/configs/exynos_defconfig b/arch/arm/configs/exynos_defconfig
index 7ad48fdda1dac69a4a9612eabb573729bed7b3a6..251f45be6c14af59263373f21b27b15f42ec7f61 100644
--- a/arch/arm/configs/exynos_defconfig
+++ b/arch/arm/configs/exynos_defconfig
@@ -167,7 +167,7 @@ CONFIG_MFD_MAX77686=y
 CONFIG_MFD_MAX77693=y
 CONFIG_MFD_MAX8997=y
 CONFIG_MFD_MAX8998=y
-CONFIG_MFD_SEC_CORE=y
+CONFIG_MFD_SEC_I2C=y
 CONFIG_MFD_STMPE=y
 CONFIG_STMPE_I2C=y
 CONFIG_MFD_TPS65090=y
diff --git a/arch/arm/configs/multi_v7_defconfig b/arch/arm/configs/multi_v7_defconfig
index ad037c175fdb0ec8601c9b3607aca0c0e5f3c145..7d06ac5369b1a2f325462f2cf5b54fe22061ca77 100644
--- a/arch/arm/configs/multi_v7_defconfig
+++ b/arch/arm/configs/multi_v7_defconfig
@@ -612,7 +612,7 @@ CONFIG_MFD_QCOM_RPM=y
 CONFIG_MFD_SPMI_PMIC=y
 CONFIG_MFD_RK8XX_I2C=y
 CONFIG_MFD_RN5T618=y
-CONFIG_MFD_SEC_CORE=y
+CONFIG_MFD_SEC_I2C=y
 CONFIG_MFD_STMPE=y
 CONFIG_MFD_PALMAS=y
 CONFIG_MFD_TPS65090=y
diff --git a/arch/arm/configs/pxa_defconfig b/arch/arm/configs/pxa_defconfig
index de0ac8f521d7612704ce327e9ac16ab9e999f3d3..064e79baf20da809c9ab1f1fa18282aaba11a41f 100644
--- a/arch/arm/configs/pxa_defconfig
+++ b/arch/arm/configs/pxa_defconfig
@@ -335,7 +335,7 @@ CONFIG_MFD_MAX77693=y
 CONFIG_MFD_MAX8907=m
 CONFIG_EZX_PCAP=y
 CONFIG_UCB1400_CORE=m
-CONFIG_MFD_SEC_CORE=y
+CONFIG_MFD_SEC_I2C=y
 CONFIG_MFD_PALMAS=y
 CONFIG_MFD_TPS65090=y
 CONFIG_MFD_TPS6586X=y
diff --git a/arch/arm64/configs/defconfig b/arch/arm64/configs/defconfig
index e8dfbe22db68d9aa24df5af0786a2eeb8f33bf3c..cc4dc330cfe82d11ca0c4c9ba8cac4b14decdeab 100644
--- a/arch/arm64/configs/defconfig
+++ b/arch/arm64/configs/defconfig
@@ -769,7 +769,7 @@ CONFIG_MFD_MT6397=y
 CONFIG_MFD_SPMI_PMIC=y
 CONFIG_MFD_RK8XX_I2C=y
 CONFIG_MFD_RK8XX_SPI=y
-CONFIG_MFD_SEC_CORE=y
+CONFIG_MFD_SEC_I2C=y
 CONFIG_MFD_SL28CPLD=y
 CONFIG_RZ_MTU3=y
 CONFIG_MFD_TI_AM335X_TSCADC=m

-- 
2.49.0.395.g12beb8f557-goog

Re: [PATCH 11/34] defconfigs: rename CONFIG_MFD_SEC_CORE to CONFIG_MFD_SEC_I2C
Posted by Krzysztof Kozlowski 1 month, 2 weeks ago
On 23/03/2025 23:39, André Draszik wrote:
> We are adding support for Samsung PMICs that aren't using I2C and
> therefore had to rename the Kconfig symbol.
> 
> Signed-off-by: André Draszik <andre.draszik@linaro.org>
> ---
>  arch/arm/configs/exynos_defconfig   | 2 +-
>  arch/arm/configs/multi_v7_defconfig | 2 +-
>  arch/arm/configs/pxa_defconfig      | 2 +-
>  arch/arm64/configs/defconfig        | 2 +-
>  4 files changed, 4 insertions(+), 4 deletions(-)
defconfigs go separate tree, so this must not be in the middle of the
patchset. Bisectability, as for defconfig, is anyway broken in previous
change, so no benefit of putting this in the middle anyway.

Best regards,
Krzysztof
Re: [PATCH 11/34] defconfigs: rename CONFIG_MFD_SEC_CORE to CONFIG_MFD_SEC_I2C
Posted by André Draszik 1 month, 2 weeks ago
On Wed, 2025-03-26 at 08:16 +0100, Krzysztof Kozlowski wrote:
> On 23/03/2025 23:39, André Draszik wrote:
> > We are adding support for Samsung PMICs that aren't using I2C and
> > therefore had to rename the Kconfig symbol.
> > 
> > Signed-off-by: André Draszik <andre.draszik@linaro.org>
> > ---
> >  arch/arm/configs/exynos_defconfig   | 2 +-
> >  arch/arm/configs/multi_v7_defconfig | 2 +-
> >  arch/arm/configs/pxa_defconfig      | 2 +-
> >  arch/arm64/configs/defconfig        | 2 +-
> >  4 files changed, 4 insertions(+), 4 deletions(-)
> defconfigs go separate tree, so this must not be in the middle of the
> patchset. Bisectability, as for defconfig, is anyway broken in previous
> change, so no benefit of putting this in the middle anyway.

OK. Should it still be part of this series, e.g. at the start, after
the binding changes, or a completely separate stand-alone patch with
a reference to this series?

Cheers,
Andre'
Re: [PATCH 11/34] defconfigs: rename CONFIG_MFD_SEC_CORE to CONFIG_MFD_SEC_I2C
Posted by Krzysztof Kozlowski 1 month, 2 weeks ago
On 27/03/2025 09:56, André Draszik wrote:
> On Wed, 2025-03-26 at 08:16 +0100, Krzysztof Kozlowski wrote:
>> On 23/03/2025 23:39, André Draszik wrote:
>>> We are adding support for Samsung PMICs that aren't using I2C and
>>> therefore had to rename the Kconfig symbol.
>>>
>>> Signed-off-by: André Draszik <andre.draszik@linaro.org>
>>> ---
>>>  arch/arm/configs/exynos_defconfig   | 2 +-
>>>  arch/arm/configs/multi_v7_defconfig | 2 +-
>>>  arch/arm/configs/pxa_defconfig      | 2 +-
>>>  arch/arm64/configs/defconfig        | 2 +-
>>>  4 files changed, 4 insertions(+), 4 deletions(-)
>> defconfigs go separate tree, so this must not be in the middle of the
>> patchset. Bisectability, as for defconfig, is anyway broken in previous
>> change, so no benefit of putting this in the middle anyway.
> 
> OK. Should it still be part of this series, e.g. at the start, after
> the binding changes, or a completely separate stand-alone patch with
> a reference to this series?
Hm, now as I am thinking, maybe we should just squash it with previous
patch and take everything via MFD? defconfig could be mixed with the
drivers, it's a kernel thing, not like DTS.

Best regards,
Krzysztof
Re: [PATCH 11/34] defconfigs: rename CONFIG_MFD_SEC_CORE to CONFIG_MFD_SEC_I2C
Posted by André Draszik 1 month, 2 weeks ago
On Thu, 2025-03-27 at 17:57 +0100, Krzysztof Kozlowski wrote:
> On 27/03/2025 09:56, André Draszik wrote:
> > On Wed, 2025-03-26 at 08:16 +0100, Krzysztof Kozlowski wrote:
> > > On 23/03/2025 23:39, André Draszik wrote:
> > > > We are adding support for Samsung PMICs that aren't using I2C and
> > > > therefore had to rename the Kconfig symbol.
> > > > 
> > > > Signed-off-by: André Draszik <andre.draszik@linaro.org>
> > > > ---
> > > >  arch/arm/configs/exynos_defconfig   | 2 +-
> > > >  arch/arm/configs/multi_v7_defconfig | 2 +-
> > > >  arch/arm/configs/pxa_defconfig      | 2 +-
> > > >  arch/arm64/configs/defconfig        | 2 +-
> > > >  4 files changed, 4 insertions(+), 4 deletions(-)
> > > defconfigs go separate tree, so this must not be in the middle of the
> > > patchset. Bisectability, as for defconfig, is anyway broken in previous
> > > change, so no benefit of putting this in the middle anyway.
> > 
> > OK. Should it still be part of this series, e.g. at the start, after
> > the binding changes, or a completely separate stand-alone patch with
> > a reference to this series?
> Hm, now as I am thinking, maybe we should just squash it with previous
> patch and take everything via MFD? defconfig could be mixed with the
> drivers, it's a kernel thing, not like DTS.

Happy to do that, and it would also ensure bisectability :-)

Cheers,
Andre'