On 12/4/24 06:08, Patryk Wlazlyn wrote:
> Changes since v7:
> * Doing the s/mwait_play_dead/mwait_play_dead_cpuid_hint/
> and s/mwait_play_dead_with_hint/mwait_play_dead/
>
> as suggested by Gautham. It was a left-over from previous patches.
> The function(s) got renamed in the patches and I forgot to update
> the changelog accordingly for patch 4/4.
>
> Patryk Wlazlyn (4):
> x86/smp: Allow calling mwait_play_dead with an arbitrary hint
> ACPI: processor_idle: Add FFH state handling
> intel_idle: Provide the default enter_dead() handler
> x86/smp native_play_dead: Prefer cpuidle_play_dead() over
> mwait_play_dead()
>
> arch/x86/include/asm/smp.h | 3 +++
> arch/x86/kernel/acpi/cstate.c | 10 ++++++++
> arch/x86/kernel/smpboot.c | 46 ++++-------------------------------
> drivers/acpi/processor_idle.c | 2 ++
> drivers/idle/intel_idle.c | 18 ++++++++++++--
> include/acpi/processor.h | 5 ++++
> 6 files changed, 41 insertions(+), 43 deletions(-)
Hey Patryk,
I know this series is up to v8 and we all know what it's about. But it
would be much appreciated in the future if you could send along a cover
letter. It's important and really does help reviewers dive into a series
more efficiently.