[PATCH] mm: Rename folioq_count to folioq_full in documentation to match function

Tamir Hadash posted 1 patch 1 month, 3 weeks ago
include/linux/folio_queue.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
[PATCH] mm: Rename folioq_count to folioq_full in documentation to match function
Posted by Tamir Hadash 1 month, 3 weeks ago
This patch updates the documentation to correctly reflect the function names in the memory management code.

Previously, both the folioq_count and folioq_full functions had documentation incorrectly referring to folioq_count. This caused confusion and warnings when building the Linux kernel's HTML documentation.

The documentation for folioq_full has been renamed to match the correct function name, resolving these issues and improving consistency between the function definitions and their respective documentation.

Signed-off-by: Tamir Hadash <udbe3333@gmail.com>
---
 include/linux/folio_queue.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/linux/folio_queue.h b/include/linux/folio_queue.h
index af871405ae55..3abe614ef5f0 100644
--- a/include/linux/folio_queue.h
+++ b/include/linux/folio_queue.h
@@ -81,7 +81,7 @@ static inline unsigned int folioq_count(struct folio_queue *folioq)
 }
 
 /**
- * folioq_count: Query if a folio queue segment is full
+ * folioq_full: Query if a folio queue segment is full
  * @folioq: The segment to query
  *
  * Query if a folio queue segment is fully occupied.  Note that this does not
-- 
2.46.2