[PATCH] Improve comment of get_random_bytes function

William Zijl posted 1 patch 1 year, 6 months ago
There is a newer version of this series
drivers/char/random.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
[PATCH] Improve comment of get_random_bytes function
Posted by William Zijl 1 year, 6 months ago
The old comment of this function had a double whitespace and contained
grammatical errors, such as: `the randomness by this function`, `at
least once at any point prior`. This patch replaces those sentenced with
`the randomness of this function`, `at any point prior to this`
respectively.

Signed-off-by: William Zijl <postmaster@gusted.xyz>
---
 drivers/char/random.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/char/random.c b/drivers/char/random.c
index 64ee16ffb8b7..e0b1b31789a5 100644
--- a/drivers/char/random.c
+++ b/drivers/char/random.c
@@ -382,11 +382,11 @@ static void _get_random_bytes(void *buf, size_t len)
 }
 
 /*
- * This function is the exported kernel interface.  It returns some
- * number of good random numbers, suitable for key generation, seeding
- * TCP sequence numbers, etc. In order to ensure that the randomness
- * by this function is okay, the function wait_for_random_bytes()
- * should be called and return 0 at least once at any point prior.
+ * This function is the exported kernel interface. It returns some number
+ * of good random numbers, suitable for key generation, seeding TCP
+ * sequence numbers, etc. In order to ensure that the randomness of this
+ * function is okay, the function wait_for_random_bytes() should be called
+ * and return 0 at least once at any point prior to this.
  */
 void get_random_bytes(void *buf, size_t len)
 {
-- 
2.37.3
Re: [PATCH] Improve comment of get_random_bytes function
Posted by Bagas Sanjaya 1 year, 6 months ago
On Sat, Oct 01, 2022 at 02:18:31AM +0200, William Zijl wrote:
> The old comment of this function had a double whitespace and contained
> grammatical errors, such as: `the randomness by this function`, `at
> least once at any point prior`. This patch replaces those sentenced with
> `the randomness of this function`, `at any point prior to this`
> respectively.

s/This patch replaces/Replace/

Why? See Documentation/process/submitting-patches.rst.

-- 
An old man doll... just what I always wanted! - Clara
Re: [PATCH] Improve comment of get_random_bytes function
Posted by Jason A. Donenfeld 1 year, 6 months ago
On Sat, Oct 01, 2022 at 02:18:31AM +0200, William Zijl wrote:
> The old comment of this function had a double whitespace and contained
> grammatical errors, such as: `the randomness by this function`, `at
> least once at any point prior`. This patch replaces those sentenced with
> `the randomness of this function`, `at any point prior to this`
> respectively.

"at any point prior" seems fine to me.

"the randomness by this function" is wrong, but the correction for it
should be "the randomness returned by this function".

Feel free to submit a v2.

Jason