[Qemu-devel] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()

Peter Maydell posted 2 patches 5 years, 4 months ago
Test asan passed
Test checkpatch passed
Test docker-quick@centos7 passed
Test docker-mingw@fedora passed
Test docker-clang@ubuntu passed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20181122133507.30950-1-peter.maydell@linaro.org
include/exec/cpu-common.h   |  2 --
include/exec/memory.h       | 26 ++++++++++++++++++++++++++
exec.c                      | 30 +++++++++++++++++++-----------
hw/core/loader.c            |  4 ++--
hw/intc/apic.c              |  7 ++++---
hw/misc/tz-mpc.c            |  2 +-
hw/sparc/sun4m.c            |  5 +++--
docs/devel/loads-stores.rst | 35 ++++++++++++++++-------------------
8 files changed, 71 insertions(+), 40 deletions(-)
[Qemu-devel] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Posted by Peter Maydell 5 years, 4 months ago
The API of cpu_physical_memory_write_rom() is odd, because it
takes an AddressSpace, unlike all the other cpu_physical_memory_*
access functions. We note this oddity as a TODO in the
docs/devel/loads-stores.rst documentation.

Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
and give it an API that matches address_space_write().
We also adjest the cpu_physical_memory_write_rom_internal()
function which is local to exec.c similarly.

thanks
-- PMM
    
Peter Maydell (2):
  exec.c: Rename cpu_physical_memory_write_rom_internal()
  Rename cpu_physical_memory_write_rom() to address_space_write_rom()

 include/exec/cpu-common.h   |  2 --
 include/exec/memory.h       | 26 ++++++++++++++++++++++++++
 exec.c                      | 30 +++++++++++++++++++-----------
 hw/core/loader.c            |  4 ++--
 hw/intc/apic.c              |  7 ++++---
 hw/misc/tz-mpc.c            |  2 +-
 hw/sparc/sun4m.c            |  5 +++--
 docs/devel/loads-stores.rst | 35 ++++++++++++++++-------------------
 8 files changed, 71 insertions(+), 40 deletions(-)

-- 
2.19.1


Re: [Qemu-devel] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Posted by Philippe Mathieu-Daudé 5 years, 4 months ago
Le jeu. 22 nov. 2018 14:36, Peter Maydell <peter.maydell@linaro.org> a
écrit :

> The API of cpu_physical_memory_write_rom() is odd, because it
> takes an AddressSpace, unlike all the other cpu_physical_memory_*
> access functions. We note this oddity as a TODO in the
> docs/devel/loads-stores.rst documentation.
>
> Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
> and give it an API that matches address_space_write().
> We also adjest the cpu_physical_memory_write_rom_internal()
> function which is local to exec.c similarly.
>
> thanks
> -- PMM
>
> Peter Maydell (2):
>   exec.c: Rename cpu_physical_memory_write_rom_internal()
>   Rename cpu_physical_memory_write_rom() to address_space_write_rom()
>

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Re: [Qemu-devel] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Posted by Michael S. Tsirkin 5 years, 4 months ago
On Thu, Nov 22, 2018 at 01:35:05PM +0000, Peter Maydell wrote:
> The API of cpu_physical_memory_write_rom() is odd, because it
> takes an AddressSpace, unlike all the other cpu_physical_memory_*
> access functions. We note this oddity as a TODO in the
> docs/devel/loads-stores.rst documentation.
> 
> Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
> and give it an API that matches address_space_write().
> We also adjest the cpu_physical_memory_write_rom_internal()
> function which is local to exec.c similarly.
> 
> thanks
> -- PMM


Acked-by: Michael S. Tsirkin <mst@redhat.com>

> Peter Maydell (2):
>   exec.c: Rename cpu_physical_memory_write_rom_internal()
>   Rename cpu_physical_memory_write_rom() to address_space_write_rom()
> 
>  include/exec/cpu-common.h   |  2 --
>  include/exec/memory.h       | 26 ++++++++++++++++++++++++++
>  exec.c                      | 30 +++++++++++++++++++-----------
>  hw/core/loader.c            |  4 ++--
>  hw/intc/apic.c              |  7 ++++---
>  hw/misc/tz-mpc.c            |  2 +-
>  hw/sparc/sun4m.c            |  5 +++--
>  docs/devel/loads-stores.rst | 35 ++++++++++++++++-------------------
>  8 files changed, 71 insertions(+), 40 deletions(-)
> 
> -- 
> 2.19.1

Re: [Qemu-devel] [Qemu-arm] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Posted by Peter Maydell 5 years, 4 months ago
On Thu, 22 Nov 2018 at 13:35, Peter Maydell <peter.maydell@linaro.org> wrote:
>
> The API of cpu_physical_memory_write_rom() is odd, because it
> takes an AddressSpace, unlike all the other cpu_physical_memory_*
> access functions. We note this oddity as a TODO in the
> docs/devel/loads-stores.rst documentation.
>
> Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
> and give it an API that matches address_space_write().
> We also adjest the cpu_physical_memory_write_rom_internal()
> function which is local to exec.c similarly.

Unless somebody would prefer a different route, I'm going
to add this series to a 'misc' pullreq I'm putting together.

thanks
-- PMM

Re: [Qemu-devel] [Qemu-arm] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Posted by Paolo Bonzini 5 years, 4 months ago
On 14/12/18 12:32, Peter Maydell wrote:
> On Thu, 22 Nov 2018 at 13:35, Peter Maydell <peter.maydell@linaro.org> wrote:
>>
>> The API of cpu_physical_memory_write_rom() is odd, because it
>> takes an AddressSpace, unlike all the other cpu_physical_memory_*
>> access functions. We note this oddity as a TODO in the
>> docs/devel/loads-stores.rst documentation.
>>
>> Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
>> and give it an API that matches address_space_write().
>> We also adjest the cpu_physical_memory_write_rom_internal()
>> function which is local to exec.c similarly.
> 
> Unless somebody would prefer a different route, I'm going
> to add this series to a 'misc' pullreq I'm putting together.

Go ahead, please.

Paolo