[PATCH v1] rpm: adjust xenlight requirements

Olaf Hering posted 1 patch 2 weeks, 3 days ago
Test syntax-check failed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/libvirt tags/patchew/20210108101448.7691-1-olaf@aepfle.de
libvirt.spec.in | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

[PATCH v1] rpm: adjust xenlight requirements

Posted by Olaf Hering 2 weeks, 3 days ago
According to meson.build, and the actual code, Xen 4.6+ is required.

Signed-off-by: Olaf Hering <olaf@aepfle.de>
---
 libvirt.spec.in | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 0a8b0ebad4..bd6e7c2747 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -126,7 +126,7 @@
 %endif
 
 # RHEL doesn't ship OpenVZ, VBox, PowerHypervisor,
-# VMware, libxenlight (Xen 4.1 and newer),
+# VMware, libxenlight (Xen 4.6 and newer),
 # or HyperV.
 %if 0%{?rhel}
     %define with_openvz 0
@@ -272,7 +272,7 @@ BuildRequires: perl
 BuildRequires: python3
 BuildRequires: systemd-units
 %if %{with_libxl}
-BuildRequires: xen-devel
+BuildRequires: pkgconfig(xenlight) >= 4.6.0
 %endif
 BuildRequires: glib2-devel >= 2.48
 BuildRequires: libxml2-devel

Re: [PATCH v1] rpm: adjust xenlight requirements

Posted by Daniel P. Berrangé 2 weeks, 3 days ago
On Fri, Jan 08, 2021 at 11:14:48AM +0100, Olaf Hering wrote:
> According to meson.build, and the actual code, Xen 4.6+ is required.
> 
> Signed-off-by: Olaf Hering <olaf@aepfle.de>
> ---
>  libvirt.spec.in | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/libvirt.spec.in b/libvirt.spec.in
> index 0a8b0ebad4..bd6e7c2747 100644
> --- a/libvirt.spec.in
> +++ b/libvirt.spec.in
> @@ -126,7 +126,7 @@
>  %endif
>  
>  # RHEL doesn't ship OpenVZ, VBox, PowerHypervisor,
> -# VMware, libxenlight (Xen 4.1 and newer),
> +# VMware, libxenlight (Xen 4.6 and newer),

Just remove the version info entirely here.

>  # or HyperV.
>  %if 0%{?rhel}
>      %define with_openvz 0
> @@ -272,7 +272,7 @@ BuildRequires: perl
>  BuildRequires: python3
>  BuildRequires: systemd-units
>  %if %{with_libxl}
> -BuildRequires: xen-devel
> +BuildRequires: pkgconfig(xenlight) >= 4.6.0

This is not required, as per the comment at the top of file we assume
modern Fedora, so won't ever see an old Xen.


Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|