[PATCH] console: use more appropriate domain RCU-locking function

Jan Beulich posted 1 patch 1 year, 1 month ago
Failed in applying to current master (apply log)
[PATCH] console: use more appropriate domain RCU-locking function
Posted by Jan Beulich 1 year, 1 month ago
While both 19afff14b4cb ("xen: support console_switching between Dom0
and DomUs on ARM") and 1ee1e4b0d1ff ("xen/arm: Allow vpl011 to be used
by DomU") were part of the same series (iirc), the latter correctly used
rcu_lock_domain_by_id() in console_input_domain(), whereas the former
for some reason used rcu_lock_domain_by_any_id() instead, despite that
code only kind of open-coding console_input_domain(). There's no point
here to deal with DOMID_SELF, which is the sole difference between the
two functions.

Signed-off-by: Jan Beulich <jbeulich@suse.com>

--- a/xen/drivers/char/console.c
+++ b/xen/drivers/char/console.c
@@ -525,7 +525,7 @@ static void __serial_rx(char c, struct c
 #ifdef CONFIG_SBSA_VUART_CONSOLE
     default:
     {
-        struct domain *d = rcu_lock_domain_by_any_id(console_rx - 1);
+        struct domain *d = rcu_lock_domain_by_id(console_rx - 1);
 
         /*
          * If we have a properly initialized vpl011 console for the
Re: [PATCH] console: use more appropriate domain RCU-locking function
Posted by Andrew Cooper 1 year, 1 month ago
On 15/03/2023 7:24 am, Jan Beulich wrote:
> While both 19afff14b4cb ("xen: support console_switching between Dom0
> and DomUs on ARM") and 1ee1e4b0d1ff ("xen/arm: Allow vpl011 to be used
> by DomU") were part of the same series (iirc), the latter correctly used
> rcu_lock_domain_by_id() in console_input_domain(), whereas the former
> for some reason used rcu_lock_domain_by_any_id() instead, despite that
> code only kind of open-coding console_input_domain(). There's no point
> here to deal with DOMID_SELF, which is the sole difference between the
> two functions.
>
> Signed-off-by: Jan Beulich <jbeulich@suse.com>

Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>