[PATCH] drivers/xen: use helper macro __ATTR_RW

zhanglianjie posted 1 patch 2 years, 2 months ago
Failed in applying to current master (apply log)
[PATCH] drivers/xen: use helper macro __ATTR_RW
Posted by zhanglianjie 2 years, 2 months ago
Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear.
Minor readability improvement.

Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com>

diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c
index feb1d16252e7..fcb0792f090e 100644
--- a/drivers/xen/sys-hypervisor.c
+++ b/drivers/xen/sys-hypervisor.c
@@ -22,11 +22,10 @@
 #endif

 #define HYPERVISOR_ATTR_RO(_name) \
-static struct hyp_sysfs_attr  _name##_attr = __ATTR_RO(_name)
+static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name)

 #define HYPERVISOR_ATTR_RW(_name) \
-static struct hyp_sysfs_attr _name##_attr = \
-	__ATTR(_name, 0644, _name##_show, _name##_store)
+static struct hyp_sysfs_attr _name##_attr = __ATTR_RW(_name)

 struct hyp_sysfs_attr {
 	struct attribute attr;
--
2.20.1
Re: [PATCH] drivers/xen: use helper macro __ATTR_RW
Posted by Boris Ostrovsky 2 years, 1 month ago
On 3/5/22 8:38 AM, zhanglianjie wrote:
> Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear.
> Minor readability improvement.
>
> Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com>


Reviewed-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>


Applied to for-linus-5.18 (with whitespace change noted in commit message)
Re: [PATCH] drivers/xen: use helper macro __ATTR_RW
Posted by Greg Kroah-Hartman 2 years, 2 months ago
On Sat, Mar 05, 2022 at 09:38:23PM +0800, zhanglianjie wrote:
> Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear.
> Minor readability improvement.
> 
> Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com>

Is this the name you sign legal documents with?  (I have to ask...)

> 
> diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c
> index feb1d16252e7..fcb0792f090e 100644
> --- a/drivers/xen/sys-hypervisor.c
> +++ b/drivers/xen/sys-hypervisor.c
> @@ -22,11 +22,10 @@
>  #endif
> 
>  #define HYPERVISOR_ATTR_RO(_name) \
> -static struct hyp_sysfs_attr  _name##_attr = __ATTR_RO(_name)
> +static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name)

Why change this line?  That's not relevant to this change :(

thanks,

greg k-h
Re: [PATCH] drivers/xen: use helper macro __ATTR_RW
Posted by zhanglianjie 2 years, 2 months ago
Hi,

在 2022/3/5 21:55, Greg Kroah-Hartman 写道:
> On Sat, Mar 05, 2022 at 09:38:23PM +0800, zhanglianjie wrote:
>> Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear.
>> Minor readability improvement.
>>
>> Signed-off-by: zhanglianjie <zhanglianjie@uniontech.com>
> 
> Is this the name you sign legal documents with?  (I have to ask...)
Yes, this is my signature.
> 
>>
>> diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c
>> index feb1d16252e7..fcb0792f090e 100644
>> --- a/drivers/xen/sys-hypervisor.c
>> +++ b/drivers/xen/sys-hypervisor.c
>> @@ -22,11 +22,10 @@
>>   #endif
>>
>>   #define HYPERVISOR_ATTR_RO(_name) \
>> -static struct hyp_sysfs_attr  _name##_attr = __ATTR_RO(_name)
>> +static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name)
> 
> Why change this line?  That's not relevant to this change :(
> 
There are two spaces between struct hyp_sysfs_attr and _name, by the 
way, modify it.
thanks.
> thanks,
> 
> greg k-h
>