[SeaBIOS] [PATCH 0/9] Improve comments in stdvga.c

Kevin O'Connor posted 9 patches 1 month ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/seabios tags/patchew/20240401155420.880666-1-kevin@koconnor.net
vgasrc/stdvga.c      | 103 ++++++++++++++++++++++++++++---------------
vgasrc/stdvga.h      |  17 +++----
vgasrc/stdvgamodes.c |  95 +++++++++++++++++++++------------------
vgasrc/vgabios.c     |  31 +++++++------
4 files changed, 144 insertions(+), 102 deletions(-)
[SeaBIOS] [PATCH 0/9] Improve comments in stdvga.c
Posted by Kevin O'Connor 1 month ago
This series adds comments to vgasrc/stdvga.c along with some variable
and function renaming.  The goal is to make it a little easier to
understand this legacy code.

There should be no functionality changes with this patch series.

-Kevin


Kevin O'Connor (9):
  stdvgamodes: No need to store pelmask in vga_modes[]
  stdvgamodes: Improve naming of dac palette tables
  stdvga: Rename CGA palette functions
  stdvga: Add comments to interface functions in stdvga.c
  stdvga: Rename stdvga_toggle_intensity() to
    stdvga_set_palette_blinking()
  stdvga: Rework stdvga palette index paging interface functions
  stdvga: Rename stdvga_set_text_block_specifier() to
    stdvga_set_font_location()
  stdvga: Rename stdvga_set_scan_lines() to
    stdvga_set_character_height()
  stdvga: Rename stdvga_get_vde() to stdvga_get_vertical_size()

 vgasrc/stdvga.c      | 103 ++++++++++++++++++++++++++++---------------
 vgasrc/stdvga.h      |  17 +++----
 vgasrc/stdvgamodes.c |  95 +++++++++++++++++++++------------------
 vgasrc/vgabios.c     |  31 +++++++------
 4 files changed, 144 insertions(+), 102 deletions(-)

-- 
2.44.0

_______________________________________________
SeaBIOS mailing list -- seabios@seabios.org
To unsubscribe send an email to seabios-leave@seabios.org
[SeaBIOS] Re: [PATCH 0/9] Improve comments in stdvga.c
Posted by Kevin O'Connor 3 weeks, 2 days ago
On Mon, Apr 01, 2024 at 11:51:22AM -0400, Kevin O'Connor wrote:
> This series adds comments to vgasrc/stdvga.c along with some variable
> and function renaming.  The goal is to make it a little easier to
> understand this legacy code.
> 
> There should be no functionality changes with this patch series.
> 
> -Kevin

I committed this patch series.  (During merge I also fixed a minor
comment spelling error in patch 6.)

-Kevin
_______________________________________________
SeaBIOS mailing list -- seabios@seabios.org
To unsubscribe send an email to seabios-leave@seabios.org