[PULL 03/18] tests/functional: Provide a proper name for the VMs in the replay tests

Thomas Huth posted 18 patches 1 month ago
[PULL 03/18] tests/functional: Provide a proper name for the VMs in the replay tests
Posted by Thomas Huth 1 month ago
With a proper name the log files get a more meaningful name.

Signed-off-by: Thomas Huth <thuth@redhat.com>
Message-ID: <20250218152744.228335-2-thuth@redhat.com>
---
 tests/functional/replay_kernel.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/functional/replay_kernel.py b/tests/functional/replay_kernel.py
index 8e8ac7d052f..80795eb0520 100644
--- a/tests/functional/replay_kernel.py
+++ b/tests/functional/replay_kernel.py
@@ -34,7 +34,7 @@ def run_vm(self, kernel_path, kernel_command_line, console_pattern,
 
         logger = logging.getLogger('replay')
         start_time = time.time()
-        vm = self.get_vm()
+        vm = self.get_vm(name='recording' if record else 'replay')
         vm.set_console()
         if record:
             logger.info('recording the execution...')
-- 
2.48.1