[RFC PATCH] hw/virtio: fix confusing comment

Dmitry Frolov posted 1 patch 1 year ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20231124120846.2499854-1-frolov@swemel.ru
Maintainers: "Michael S. Tsirkin" <mst@redhat.com>
include/hw/virtio/virtio-pci.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
[RFC PATCH] hw/virtio: fix confusing comment
Posted by Dmitry Frolov 1 year ago
It seems that comments to transitional/non-transitional devices are
mixed up.

Signed-off-by: Dmitry Frolov <frolov@swemel.ru>
---
 include/hw/virtio/virtio-pci.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/hw/virtio/virtio-pci.h b/include/hw/virtio/virtio-pci.h
index 5a3f182f99..45be10d694 100644
--- a/include/hw/virtio/virtio-pci.h
+++ b/include/hw/virtio/virtio-pci.h
@@ -229,13 +229,13 @@ typedef struct VirtioPCIDeviceTypeInfo {
     /*
      * The transitional device type.  Optional.
      *
-     * Implements both INTERFACE_PCIE_DEVICE and INTERFACE_CONVENTIONAL_PCI_DEVICE.
+     * Implements INTERFACE_CONVENTIONAL_PCI_DEVICE only.
      */
     const char *transitional_name;
     /*
      * The non-transitional device type.  Optional.
      *
-     * Implements INTERFACE_CONVENTIONAL_PCI_DEVICE only.
+     * Implements both INTERFACE_PCIE_DEVICE and INTERFACE_CONVENTIONAL_PCI_DEVICE.
      */
     const char *non_transitional_name;
 
-- 
2.34.1