[PATCH v3 4/5] tests/unit/test-io-task: Rename "qemu:dummy" to avoid colon in the name

Thomas Huth posted 5 patches 1 year ago
Maintainers: Alistair Francis <alistair@alistair23.me>, "Edgar E. Iglesias" <edgar.iglesias@gmail.com>, Peter Maydell <peter.maydell@linaro.org>, Paolo Bonzini <pbonzini@redhat.com>, Peter Xu <peterx@redhat.com>, David Hildenbrand <david@redhat.com>, "Philippe Mathieu-Daudé" <philmd@linaro.org>, Francisco Iglesias <francisco.iglesias@amd.com>, "Daniel P. Berrangé" <berrange@redhat.com>, Eduardo Habkost <eduardo@habkost.net>
[PATCH v3 4/5] tests/unit/test-io-task: Rename "qemu:dummy" to avoid colon in the name
Posted by Thomas Huth 1 year ago
Type names should not contain special characters like ":" (so that
they are easier to use with QAPI and other parts). We are going to
forbid such names in an upcoming patch. Thus let's replace the ":"
here with a "-".

Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Signed-off-by: Thomas Huth <thuth@redhat.com>
---
 tests/unit/test-io-task.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/unit/test-io-task.c b/tests/unit/test-io-task.c
index 953a50ae66..115dba8970 100644
--- a/tests/unit/test-io-task.c
+++ b/tests/unit/test-io-task.c
@@ -25,7 +25,7 @@
 #include "qapi/error.h"
 #include "qemu/module.h"
 
-#define TYPE_DUMMY "qemu:dummy"
+#define TYPE_DUMMY "qemu-dummy"
 
 typedef struct DummyObject DummyObject;
 typedef struct DummyObjectClass DummyObjectClass;
-- 
2.42.0


Re: [PATCH v3 4/5] tests/unit/test-io-task: Rename "qemu:dummy" to avoid colon in the name
Posted by Alistair Francis 1 year ago
On Fri, Nov 17, 2023 at 11:08 PM Thomas Huth <thuth@redhat.com> wrote:
>
> Type names should not contain special characters like ":" (so that
> they are easier to use with QAPI and other parts). We are going to
> forbid such names in an upcoming patch. Thus let's replace the ":"
> here with a "-".
>
> Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
> Signed-off-by: Thomas Huth <thuth@redhat.com>

Reviewed-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
>  tests/unit/test-io-task.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/tests/unit/test-io-task.c b/tests/unit/test-io-task.c
> index 953a50ae66..115dba8970 100644
> --- a/tests/unit/test-io-task.c
> +++ b/tests/unit/test-io-task.c
> @@ -25,7 +25,7 @@
>  #include "qapi/error.h"
>  #include "qemu/module.h"
>
> -#define TYPE_DUMMY "qemu:dummy"
> +#define TYPE_DUMMY "qemu-dummy"
>
>  typedef struct DummyObject DummyObject;
>  typedef struct DummyObjectClass DummyObjectClass;
> --
> 2.42.0
>
>