[PATCH] Revert "hw/sparc64/niagara: Use blk_name() instead of open-coding it"

Markus Armbruster posted 1 patch 11 months, 2 weeks ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20230515151104.1350155-1-armbru@redhat.com
Maintainers: Artyom Tarasenko <atar4qemu@gmail.com>, Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
hw/sparc64/niagara.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
[PATCH] Revert "hw/sparc64/niagara: Use blk_name() instead of open-coding it"
Posted by Markus Armbruster 11 months, 2 weeks ago
This reverts commit 1881f336a33a8a99cb17ab1c57ed953682e8e107.

This commit breaks "-drive if=pflash,readonly=on,file=image.iso".  It
claims to merely replace an open-coded version of blk_name() by a
call, but that's not the case.  Sorry for the inconvenience!

Reported-by: Jakub Jermář <jakub@jermar.eu>
Cc: qemu-stable@nongnu.org
Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 hw/sparc64/niagara.c | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/hw/sparc64/niagara.c b/hw/sparc64/niagara.c
index 6725cc61fd..ab3c4ec346 100644
--- a/hw/sparc64/niagara.c
+++ b/hw/sparc64/niagara.c
@@ -23,6 +23,7 @@
  */
 
 #include "qemu/osdep.h"
+#include "block/block_int-common.h"
 #include "qemu/units.h"
 #include "cpu.h"
 #include "hw/boards.h"
@@ -143,9 +144,10 @@ static void niagara_init(MachineState *machine)
             memory_region_add_subregion(get_system_memory(),
                                         NIAGARA_VDISK_BASE, &s->vdisk_ram);
             dinfo->is_default = 1;
-            rom_add_file_fixed(blk_name(blk), NIAGARA_VDISK_BASE, -1);
+            rom_add_file_fixed(blk_bs(blk)->filename, NIAGARA_VDISK_BASE, -1);
         } else {
-            error_report("could not load ram disk '%s'", blk_name(blk));
+            error_report("could not load ram disk '%s'",
+                         blk_bs(blk)->filename);
             exit(1);
         }
     }
-- 
2.39.2


Re: [PATCH] Revert "hw/sparc64/niagara: Use blk_name() instead of open-coding it"
Posted by Mark Cave-Ayland 10 months, 1 week ago
On 15/05/2023 16:11, Markus Armbruster wrote:

> This reverts commit 1881f336a33a8a99cb17ab1c57ed953682e8e107.
> 
> This commit breaks "-drive if=pflash,readonly=on,file=image.iso".  It
> claims to merely replace an open-coded version of blk_name() by a
> call, but that's not the case.  Sorry for the inconvenience!
> 
> Reported-by: Jakub Jermář <jakub@jermar.eu>
> Cc: qemu-stable@nongnu.org
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>   hw/sparc64/niagara.c | 6 ++++--
>   1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/hw/sparc64/niagara.c b/hw/sparc64/niagara.c
> index 6725cc61fd..ab3c4ec346 100644
> --- a/hw/sparc64/niagara.c
> +++ b/hw/sparc64/niagara.c
> @@ -23,6 +23,7 @@
>    */
>   
>   #include "qemu/osdep.h"
> +#include "block/block_int-common.h"
>   #include "qemu/units.h"
>   #include "cpu.h"
>   #include "hw/boards.h"
> @@ -143,9 +144,10 @@ static void niagara_init(MachineState *machine)
>               memory_region_add_subregion(get_system_memory(),
>                                           NIAGARA_VDISK_BASE, &s->vdisk_ram);
>               dinfo->is_default = 1;
> -            rom_add_file_fixed(blk_name(blk), NIAGARA_VDISK_BASE, -1);
> +            rom_add_file_fixed(blk_bs(blk)->filename, NIAGARA_VDISK_BASE, -1);
>           } else {
> -            error_report("could not load ram disk '%s'", blk_name(blk));
> +            error_report("could not load ram disk '%s'",
> +                         blk_bs(blk)->filename);
>               exit(1);
>           }
>       }

Thanks - I've queued this to my qemu-sparc branch.


ATB,

Mark.


Re: [PATCH] Revert "hw/sparc64/niagara: Use blk_name() instead of open-coding it"
Posted by Mark Cave-Ayland 11 months, 2 weeks ago
On 15/05/2023 16:11, Markus Armbruster wrote:

> This reverts commit 1881f336a33a8a99cb17ab1c57ed953682e8e107.
> 
> This commit breaks "-drive if=pflash,readonly=on,file=image.iso".  It
> claims to merely replace an open-coded version of blk_name() by a
> call, but that's not the case.  Sorry for the inconvenience!

Ah so was this a case of replacing something that shouldn't have been replaced in the 
first place, or does it require a follow-up patch?

> Reported-by: Jakub Jermář <jakub@jermar.eu>
> Cc: qemu-stable@nongnu.org
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>   hw/sparc64/niagara.c | 6 ++++--
>   1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/hw/sparc64/niagara.c b/hw/sparc64/niagara.c
> index 6725cc61fd..ab3c4ec346 100644
> --- a/hw/sparc64/niagara.c
> +++ b/hw/sparc64/niagara.c
> @@ -23,6 +23,7 @@
>    */
>   
>   #include "qemu/osdep.h"
> +#include "block/block_int-common.h"
>   #include "qemu/units.h"
>   #include "cpu.h"
>   #include "hw/boards.h"
> @@ -143,9 +144,10 @@ static void niagara_init(MachineState *machine)
>               memory_region_add_subregion(get_system_memory(),
>                                           NIAGARA_VDISK_BASE, &s->vdisk_ram);
>               dinfo->is_default = 1;
> -            rom_add_file_fixed(blk_name(blk), NIAGARA_VDISK_BASE, -1);
> +            rom_add_file_fixed(blk_bs(blk)->filename, NIAGARA_VDISK_BASE, -1);
>           } else {
> -            error_report("could not load ram disk '%s'", blk_name(blk));
> +            error_report("could not load ram disk '%s'",
> +                         blk_bs(blk)->filename);
>               exit(1);
>           }
>       }

Regardless of the above:

Acked-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>


ATB,

Mark.


Re: [PATCH] Revert "hw/sparc64/niagara: Use blk_name() instead of open-coding it"
Posted by Markus Armbruster 11 months, 2 weeks ago
Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk> writes:

> On 15/05/2023 16:11, Markus Armbruster wrote:
>
>> This reverts commit 1881f336a33a8a99cb17ab1c57ed953682e8e107.
>> This commit breaks "-drive if=pflash,readonly=on,file=image.iso".  It
>> claims to merely replace an open-coded version of blk_name() by a
>> call, but that's not the case.  Sorry for the inconvenience!
>
> Ah so was this a case of replacing something that shouldn't have been replaced in the first place, or does it require a follow-up patch?

I was looking at inclusions of block/block_int*.h outside the block
subsystem, and went "Oh, I can get rid of this one!"  Nope, brain
malfunction.

Reducing such inclusions is always nice, but the code this patch
restores isn't broken, and no follow-up fix is required.

>> Reported-by: Jakub Jermář <jakub@jermar.eu>
>> Cc: qemu-stable@nongnu.org
>> Signed-off-by: Markus Armbruster <armbru@redhat.com>

[...]

> Regardless of the above:
>
> Acked-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>

Thanks!
Re: [PATCH] Revert "hw/sparc64/niagara: Use blk_name() instead of open-coding it"
Posted by Philippe Mathieu-Daudé 11 months, 2 weeks ago
On 16/5/23 10:04, Markus Armbruster wrote:
> Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk> writes:
> 
>> On 15/05/2023 16:11, Markus Armbruster wrote:
>>
>>> This reverts commit 1881f336a33a8a99cb17ab1c57ed953682e8e107.
>>> This commit breaks "-drive if=pflash,readonly=on,file=image.iso".  It
>>> claims to merely replace an open-coded version of blk_name() by a
>>> call, but that's not the case.  Sorry for the inconvenience!
>>
>> Ah so was this a case of replacing something that shouldn't have been replaced in the first place, or does it require a follow-up patch?
> 
> I was looking at inclusions of block/block_int*.h outside the block
> subsystem, and went "Oh, I can get rid of this one!"  Nope, brain
> malfunction.

x2, sorry :/

Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>

> Reducing such inclusions is always nice, but the code this patch
> restores isn't broken, and no follow-up fix is required.
> 
>>> Reported-by: Jakub Jermář <jakub@jermar.eu>
>>> Cc: qemu-stable@nongnu.org
>>> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> 
> [...]
> 
>> Regardless of the above:
>>
>> Acked-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
> 
> Thanks!
> 
>