[PATCH] virtio-iommu: Remove non transitional name

Eric Auger posted 1 patch 2 years, 6 months ago
Test checkpatch passed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20211013095554.758806-1-eric.auger@redhat.com
Maintainers: "Michael S. Tsirkin" <mst@redhat.com>, Eric Auger <eric.auger@redhat.com>
hw/virtio/virtio-iommu-pci.c | 1 -
1 file changed, 1 deletion(-)
[PATCH] virtio-iommu: Remove non transitional name
Posted by Eric Auger 2 years, 6 months ago
Remove non transitional name for virtio iommu. Like other
devices introduced after 1.0 spec, the virtio-iommu does
not need it.

Signed-off-by: Eric Auger <eric.auger@redhat.com>
Reported-by: Andrea Bolognani <abologna@redhat.com>
---
 hw/virtio/virtio-iommu-pci.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/hw/virtio/virtio-iommu-pci.c b/hw/virtio/virtio-iommu-pci.c
index 770c286be7..86fa4e6c28 100644
--- a/hw/virtio/virtio-iommu-pci.c
+++ b/hw/virtio/virtio-iommu-pci.c
@@ -100,7 +100,6 @@ static void virtio_iommu_pci_instance_init(Object *obj)
 static const VirtioPCIDeviceTypeInfo virtio_iommu_pci_info = {
     .base_name             = TYPE_VIRTIO_IOMMU_PCI,
     .generic_name          = "virtio-iommu-pci",
-    .non_transitional_name = "virtio-iommu-pci-non-transitional",
     .instance_size = sizeof(VirtIOIOMMUPCI),
     .instance_init = virtio_iommu_pci_instance_init,
     .class_init    = virtio_iommu_pci_class_init,
-- 
2.27.0


Re: [PATCH] virtio-iommu: Remove non transitional name
Posted by Cornelia Huck 2 years, 6 months ago
On Wed, Oct 13 2021, Eric Auger <eric.auger@redhat.com> wrote:

> Remove non transitional name for virtio iommu. Like other
> devices introduced after 1.0 spec, the virtio-iommu does
> not need it.
>
> Signed-off-by: Eric Auger <eric.auger@redhat.com>
> Reported-by: Andrea Bolognani <abologna@redhat.com>
> ---
>  hw/virtio/virtio-iommu-pci.c | 1 -
>  1 file changed, 1 deletion(-)
>
> diff --git a/hw/virtio/virtio-iommu-pci.c b/hw/virtio/virtio-iommu-pci.c
> index 770c286be7..86fa4e6c28 100644
> --- a/hw/virtio/virtio-iommu-pci.c
> +++ b/hw/virtio/virtio-iommu-pci.c
> @@ -100,7 +100,6 @@ static void virtio_iommu_pci_instance_init(Object *obj)
>  static const VirtioPCIDeviceTypeInfo virtio_iommu_pci_info = {
>      .base_name             = TYPE_VIRTIO_IOMMU_PCI,
>      .generic_name          = "virtio-iommu-pci",
> -    .non_transitional_name = "virtio-iommu-pci-non-transitional",
>      .instance_size = sizeof(VirtIOIOMMUPCI),
>      .instance_init = virtio_iommu_pci_instance_init,
>      .class_init    = virtio_iommu_pci_class_init,

No objections, but I'm a bit confused regarding base_name and
generic_name here. Can you drop base_name, re-define
TYPE_VIRTIO_IOMMU_PCI to "virtio-iommu-pci", and switch generic_name
over to it? I think that would be more in line with other modern-only
devices. AFAICS, the places using the #define should continue to work.


Re: [PATCH] virtio-iommu: Remove non transitional name
Posted by Eric Auger 2 years, 6 months ago
Hi Connie,

On 10/13/21 12:28 PM, Cornelia Huck wrote:
> On Wed, Oct 13 2021, Eric Auger <eric.auger@redhat.com> wrote:
>
>> Remove non transitional name for virtio iommu. Like other
>> devices introduced after 1.0 spec, the virtio-iommu does
>> not need it.
>>
>> Signed-off-by: Eric Auger <eric.auger@redhat.com>
>> Reported-by: Andrea Bolognani <abologna@redhat.com>
>> ---
>>  hw/virtio/virtio-iommu-pci.c | 1 -
>>  1 file changed, 1 deletion(-)
>>
>> diff --git a/hw/virtio/virtio-iommu-pci.c b/hw/virtio/virtio-iommu-pci.c
>> index 770c286be7..86fa4e6c28 100644
>> --- a/hw/virtio/virtio-iommu-pci.c
>> +++ b/hw/virtio/virtio-iommu-pci.c
>> @@ -100,7 +100,6 @@ static void virtio_iommu_pci_instance_init(Object *obj)
>>  static const VirtioPCIDeviceTypeInfo virtio_iommu_pci_info = {
>>      .base_name             = TYPE_VIRTIO_IOMMU_PCI,
>>      .generic_name          = "virtio-iommu-pci",
>> -    .non_transitional_name = "virtio-iommu-pci-non-transitional",
>>      .instance_size = sizeof(VirtIOIOMMUPCI),
>>      .instance_init = virtio_iommu_pci_instance_init,
>>      .class_init    = virtio_iommu_pci_class_init,
> No objections, but I'm a bit confused regarding base_name and
> generic_name here. Can you drop base_name, re-define
> TYPE_VIRTIO_IOMMU_PCI to "virtio-iommu-pci", and switch generic_name
> over to it? I think that would be more in line with other modern-only
> devices. AFAICS, the places using the #define should continue to work.
>
Sure, this all makes sense to me.

Thanks!

Eric