[PATCH 0/6] misc: Some inclusive terminology changes

Philippe Mathieu-Daudé posted 6 patches 3 years, 7 months ago
Test docker-quick@centos7 failed
Test docker-mingw@fedora failed
Test checkpatch failed
Test FreeBSD failed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20200910070131.435543-1-philmd@redhat.com
include/hw/pci-host/q35.h     |  4 +--
include/hw/ssi/aspeed_smc.h   |  2 +-
include/hw/ssi/xilinx_spips.h |  2 +-
include/hw/stream.h           | 46 +++++++++++++--------------
hw/core/stream.c              | 20 ++++++------
hw/dma/xilinx_axidma.c        | 58 +++++++++++++++++------------------
hw/net/xilinx_axienet.c       | 44 +++++++++++++-------------
hw/pci-host/q35.c             | 38 +++++++++++------------
hw/ssi/aspeed_smc.c           | 40 ++++++++++++------------
hw/ssi/xilinx_spips.c         |  2 +-
target/i386/kvm.c             |  4 +--
tests/qtest/q35-test.c        |  2 +-
12 files changed, 131 insertions(+), 131 deletions(-)
[PATCH 0/6] misc: Some inclusive terminology changes
Posted by Philippe Mathieu-Daudé 3 years, 7 months ago
We don't have (yet?) inclusive terminology guidelines,
but the PCI hole memory is not "black", the DMA sources
don't stream to "slaves", and there isn't really a TSX
"black" list, we only check for broken fields.

As this terms can be considered offensive, and changing
them is a no-brain operation, simply do it.

Philippe Mathieu-Daudé (6):
  hw/ssi/aspeed_smc: Rename max_slaves as max_devices
  hw/core/stream: Rename StreamSlave as StreamSink
  hw/dma/xilinx_axidma: Rename StreamSlave as StreamSink
  hw/net/xilinx_axienet: Rename StreamSlave as StreamSink
  hw/pci-host/q35: Rename PCI 'black hole as '(memory) hole'
  target/i386/kvm: Rename host_tsx_blacklisted() as host_tsx_broken()

 include/hw/pci-host/q35.h     |  4 +--
 include/hw/ssi/aspeed_smc.h   |  2 +-
 include/hw/ssi/xilinx_spips.h |  2 +-
 include/hw/stream.h           | 46 +++++++++++++--------------
 hw/core/stream.c              | 20 ++++++------
 hw/dma/xilinx_axidma.c        | 58 +++++++++++++++++------------------
 hw/net/xilinx_axienet.c       | 44 +++++++++++++-------------
 hw/pci-host/q35.c             | 38 +++++++++++------------
 hw/ssi/aspeed_smc.c           | 40 ++++++++++++------------
 hw/ssi/xilinx_spips.c         |  2 +-
 target/i386/kvm.c             |  4 +--
 tests/qtest/q35-test.c        |  2 +-
 12 files changed, 131 insertions(+), 131 deletions(-)

-- 
2.26.2

Re: [PATCH 0/6] misc: Some inclusive terminology changes
Posted by Laurent Vivier 3 years, 7 months ago
Le 10/09/2020 à 09:01, Philippe Mathieu-Daudé a écrit :
> We don't have (yet?) inclusive terminology guidelines,
> but the PCI hole memory is not "black", the DMA sources
> don't stream to "slaves", and there isn't really a TSX
> "black" list, we only check for broken fields.
> 
> As this terms can be considered offensive, and changing
> them is a no-brain operation, simply do it.
> 

These changes are technically trivial but they are not from an ethical
point of view. I will add to the trivial branch only if they are acked
by their own maintainers.

Moreover, I think we should have a project level guideline before doing
that to be sure everyone agrees.

Thanks,
Laurent

Re: [PATCH 0/6] misc: Some inclusive terminology changes
Posted by Laurent Vivier 3 years, 7 months ago
Le 10/09/2020 à 09:01, Philippe Mathieu-Daudé a écrit :
> We don't have (yet?) inclusive terminology guidelines,
> but the PCI hole memory is not "black", the DMA sources
> don't stream to "slaves", and there isn't really a TSX
> "black" list, we only check for broken fields.
> 
> As this terms can be considered offensive, and changing
> them is a no-brain operation, simply do it.
> 
> Philippe Mathieu-Daudé (6):
>   hw/ssi/aspeed_smc: Rename max_slaves as max_devices
>   hw/core/stream: Rename StreamSlave as StreamSink
>   hw/dma/xilinx_axidma: Rename StreamSlave as StreamSink
>   hw/net/xilinx_axienet: Rename StreamSlave as StreamSink
>   hw/pci-host/q35: Rename PCI 'black hole as '(memory) hole'
>   target/i386/kvm: Rename host_tsx_blacklisted() as host_tsx_broken()
> 
>  include/hw/pci-host/q35.h     |  4 +--
>  include/hw/ssi/aspeed_smc.h   |  2 +-
>  include/hw/ssi/xilinx_spips.h |  2 +-
>  include/hw/stream.h           | 46 +++++++++++++--------------
>  hw/core/stream.c              | 20 ++++++------
>  hw/dma/xilinx_axidma.c        | 58 +++++++++++++++++------------------
>  hw/net/xilinx_axienet.c       | 44 +++++++++++++-------------
>  hw/pci-host/q35.c             | 38 +++++++++++------------
>  hw/ssi/aspeed_smc.c           | 40 ++++++++++++------------
>  hw/ssi/xilinx_spips.c         |  2 +-
>  target/i386/kvm.c             |  4 +--
>  tests/qtest/q35-test.c        |  2 +-
>  12 files changed, 131 insertions(+), 131 deletions(-)
> 

Philippe,

Could you report your series: it doesn't apply cleanly on my branch.

Thanks,
Laurent