[PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac

Peter Collingbourne posted 1 patch 3 years, 8 months ago
Test docker-quick@centos7 failed
Test docker-mingw@fedora failed
Test checkpatch failed
Test FreeBSD failed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20200804002712.27733-1-pcc@google.com
Maintainers: Peter Maydell <peter.maydell@linaro.org>
target/arm/translate-a64.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
[PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac
Posted by Peter Collingbourne 3 years, 8 months ago
The name disas_ldst_pac is misleading as it implies the existence
of authenticating store instructions, so rename it to avoid that
implication.

Signed-off-by: Peter Collingbourne <pcc@google.com>
---
 target/arm/translate-a64.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/target/arm/translate-a64.c b/target/arm/translate-a64.c
index 8c0764957c..749de2e509 100644
--- a/target/arm/translate-a64.c
+++ b/target/arm/translate-a64.c
@@ -3408,8 +3408,8 @@ static void disas_ldst_atomic(DisasContext *s, uint32_t insn,
  * W: pre-indexing flag
  * S: sign for imm9.
  */
-static void disas_ldst_pac(DisasContext *s, uint32_t insn,
-                           int size, int rt, bool is_vector)
+static void disas_ld_pac(DisasContext *s, uint32_t insn,
+                         int size, int rt, bool is_vector)
 {
     int rn = extract32(insn, 5, 5);
     bool is_wback = extract32(insn, 11, 1);
@@ -3562,7 +3562,7 @@ static void disas_ldst_reg(DisasContext *s, uint32_t insn)
             disas_ldst_reg_roffset(s, insn, opc, size, rt, is_vector);
             return;
         default:
-            disas_ldst_pac(s, insn, size, rt, is_vector);
+            disas_ld_pac(s, insn, size, rt, is_vector);
             return;
         }
         break;
-- 
2.28.0.163.g6104cc2f0b6-goog


Re: [PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac
Posted by Peter Maydell 3 years, 8 months ago
On Tue, 4 Aug 2020 at 01:27, Peter Collingbourne <pcc@google.com> wrote:
>
> The name disas_ldst_pac is misleading as it implies the existence
> of authenticating store instructions, so rename it to avoid that
> implication.
>
> Signed-off-by: Peter Collingbourne <pcc@google.com>

The use of ldst here matches the name of this group of instructions
in the Arm ARM (DDI0487F.c page C4-308, "Load/store register (pac)"),
I think.

thanks
-- PMM