[Qemu-devel] [PATCH 0/3] arm: Clean up and rename hw/arm/arm.h to hw/arm/boot.h

Peter Maydell posted 3 patches 4 years, 11 months ago
Test asan passed
Test docker-mingw@fedora passed
Test docker-clang@ubuntu passed
Test checkpatch passed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20190516163857.6430-1-peter.maydell@linaro.org
Maintainers: "Edgar E. Iglesias" <edgar.iglesias@gmail.com>, Andrey Smirnov <andrew.smirnov@gmail.com>, Jan Kiszka <jan.kiszka@web.de>, Peter Maydell <peter.maydell@linaro.org>, Alistair Francis <alistair@alistair23.me>, Andrew Baumann <Andrew.Baumann@microsoft.com>, Jean-Christophe Dubois <jcd@tribudubois.net>, Subbaraya Sundeep <sundeep.lkml@gmail.com>, Igor Mitsyanko <i.mitsyanko@gmail.com>, Andrzej Zaborowski <balrogg@gmail.com>, Peter Chubb <peter.chubb@nicta.com.au>, Andrew Jeffery <andrew@aj.id.au>, Beniamino Galvani <b.galvani@gmail.com>, Joel Stanley <joel@jms.id.au>, Rob Herring <robh@kernel.org>, "Cédric Le Goater" <clg@kaod.org>, "Philippe Mathieu-Daudé" <f4bug@amsat.org>
include/hw/arm/allwinner-a10.h    |  2 +-
include/hw/arm/aspeed_soc.h       |  2 +-
include/hw/arm/bcm2836.h          |  2 +-
include/hw/arm/{arm.h => boot.h}  | 12 ++++--------
include/hw/arm/fsl-imx25.h        |  2 +-
include/hw/arm/fsl-imx31.h        |  2 +-
include/hw/arm/fsl-imx6.h         |  2 +-
include/hw/arm/fsl-imx6ul.h       |  2 +-
include/hw/arm/fsl-imx7.h         |  2 +-
include/hw/arm/virt.h             |  2 +-
include/hw/arm/xlnx-versal.h      |  2 +-
include/hw/arm/xlnx-zynqmp.h      |  2 +-
include/hw/timer/armv7m_systick.h | 22 ++++++++++++++++++++++
hw/arm/armsse.c                   |  2 +-
hw/arm/armv7m.c                   |  2 +-
hw/arm/aspeed.c                   |  2 +-
hw/arm/boot.c                     |  2 +-
hw/arm/collie.c                   |  2 +-
hw/arm/exynos4210.c               |  2 +-
hw/arm/exynos4_boards.c           |  2 +-
hw/arm/highbank.c                 |  2 +-
hw/arm/integratorcp.c             |  2 +-
hw/arm/mainstone.c                |  2 +-
hw/arm/microbit.c                 |  2 +-
hw/arm/mps2-tz.c                  |  2 +-
hw/arm/mps2.c                     |  2 +-
hw/arm/msf2-soc.c                 |  2 +-
hw/arm/msf2-som.c                 |  2 +-
hw/arm/musca.c                    |  2 +-
hw/arm/musicpal.c                 |  2 +-
hw/arm/netduino2.c                |  2 +-
hw/arm/nrf51_soc.c                |  2 +-
hw/arm/nseries.c                  |  2 +-
hw/arm/omap1.c                    |  2 +-
hw/arm/omap2.c                    |  2 +-
hw/arm/omap_sx1.c                 |  2 +-
hw/arm/palm.c                     |  2 +-
hw/arm/raspi.c                    |  2 +-
hw/arm/realview.c                 |  2 +-
hw/arm/spitz.c                    |  2 +-
hw/arm/stellaris.c                |  2 +-
hw/arm/stm32f205_soc.c            |  2 +-
hw/arm/strongarm.c                |  2 +-
hw/arm/tosa.c                     |  2 +-
hw/arm/versatilepb.c              |  2 +-
hw/arm/vexpress.c                 |  2 +-
hw/arm/virt.c                     |  2 +-
hw/arm/xilinx_zynq.c              |  2 +-
hw/arm/xlnx-versal.c              |  2 +-
hw/arm/z2.c                       |  2 +-
hw/intc/armv7m_nvic.c             |  1 -
target/arm/arm-semi.c             |  1 -
target/arm/cpu.c                  |  1 -
target/arm/cpu64.c                |  1 -
target/arm/kvm.c                  |  1 -
target/arm/kvm32.c                |  1 -
target/arm/kvm64.c                |  1 -
57 files changed, 74 insertions(+), 63 deletions(-)
rename include/hw/arm/{arm.h => boot.h} (96%)
[Qemu-devel] [PATCH 0/3] arm: Clean up and rename hw/arm/arm.h to hw/arm/boot.h
Posted by Peter Maydell 4 years, 11 months ago
The header hw/arm/arm.h used to be a general bucket for
putting all kinds of arm-related declarations in. It now
has mostly kernel-boot related declarations, with one
exception: the declaration of the system_clock_scale global.
This patchset:
 * moves system_clock_scale to armv7m_systick.h (since that
   is the only device that uses it)
 * deletes some unnecessary #includes of hw/arm/arm.h
 * renames it to hw/arm/boot.h, since it now only has
   declarations relating to hw/arm/boot.c functionality

Since system_clock_scale is a weird thing, I have included
in the first patch an expansion of the comment describing
it to be clearer about what it does, and also a TODO note
sketching out how we could go about eradicating this global.

thanks
-- PMM

Peter Maydell (3):
  arm: Move system_clock_scale to armv7m_systick.h
  arm: Remove unnecessary includes of hw/arm/arm.h
  arm: Rename hw/arm/arm.h to hw/arm/boot.h

 include/hw/arm/allwinner-a10.h    |  2 +-
 include/hw/arm/aspeed_soc.h       |  2 +-
 include/hw/arm/bcm2836.h          |  2 +-
 include/hw/arm/{arm.h => boot.h}  | 12 ++++--------
 include/hw/arm/fsl-imx25.h        |  2 +-
 include/hw/arm/fsl-imx31.h        |  2 +-
 include/hw/arm/fsl-imx6.h         |  2 +-
 include/hw/arm/fsl-imx6ul.h       |  2 +-
 include/hw/arm/fsl-imx7.h         |  2 +-
 include/hw/arm/virt.h             |  2 +-
 include/hw/arm/xlnx-versal.h      |  2 +-
 include/hw/arm/xlnx-zynqmp.h      |  2 +-
 include/hw/timer/armv7m_systick.h | 22 ++++++++++++++++++++++
 hw/arm/armsse.c                   |  2 +-
 hw/arm/armv7m.c                   |  2 +-
 hw/arm/aspeed.c                   |  2 +-
 hw/arm/boot.c                     |  2 +-
 hw/arm/collie.c                   |  2 +-
 hw/arm/exynos4210.c               |  2 +-
 hw/arm/exynos4_boards.c           |  2 +-
 hw/arm/highbank.c                 |  2 +-
 hw/arm/integratorcp.c             |  2 +-
 hw/arm/mainstone.c                |  2 +-
 hw/arm/microbit.c                 |  2 +-
 hw/arm/mps2-tz.c                  |  2 +-
 hw/arm/mps2.c                     |  2 +-
 hw/arm/msf2-soc.c                 |  2 +-
 hw/arm/msf2-som.c                 |  2 +-
 hw/arm/musca.c                    |  2 +-
 hw/arm/musicpal.c                 |  2 +-
 hw/arm/netduino2.c                |  2 +-
 hw/arm/nrf51_soc.c                |  2 +-
 hw/arm/nseries.c                  |  2 +-
 hw/arm/omap1.c                    |  2 +-
 hw/arm/omap2.c                    |  2 +-
 hw/arm/omap_sx1.c                 |  2 +-
 hw/arm/palm.c                     |  2 +-
 hw/arm/raspi.c                    |  2 +-
 hw/arm/realview.c                 |  2 +-
 hw/arm/spitz.c                    |  2 +-
 hw/arm/stellaris.c                |  2 +-
 hw/arm/stm32f205_soc.c            |  2 +-
 hw/arm/strongarm.c                |  2 +-
 hw/arm/tosa.c                     |  2 +-
 hw/arm/versatilepb.c              |  2 +-
 hw/arm/vexpress.c                 |  2 +-
 hw/arm/virt.c                     |  2 +-
 hw/arm/xilinx_zynq.c              |  2 +-
 hw/arm/xlnx-versal.c              |  2 +-
 hw/arm/z2.c                       |  2 +-
 hw/intc/armv7m_nvic.c             |  1 -
 target/arm/arm-semi.c             |  1 -
 target/arm/cpu.c                  |  1 -
 target/arm/cpu64.c                |  1 -
 target/arm/kvm.c                  |  1 -
 target/arm/kvm32.c                |  1 -
 target/arm/kvm64.c                |  1 -
 57 files changed, 74 insertions(+), 63 deletions(-)
 rename include/hw/arm/{arm.h => boot.h} (96%)

-- 
2.20.1


Re: [Qemu-devel] [PATCH 0/3] arm: Clean up and rename hw/arm/arm.h to hw/arm/boot.h
Posted by Philippe Mathieu-Daudé 4 years, 11 months ago
On 5/16/19 6:38 PM, Peter Maydell wrote:
> The header hw/arm/arm.h used to be a general bucket for
> putting all kinds of arm-related declarations in. It now
> has mostly kernel-boot related declarations, with one
> exception: the declaration of the system_clock_scale global.
> This patchset:
>  * moves system_clock_scale to armv7m_systick.h (since that
>    is the only device that uses it)
>  * deletes some unnecessary #includes of hw/arm/arm.h
>  * renames it to hw/arm/boot.h, since it now only has
>    declarations relating to hw/arm/boot.c functionality

Yay \o/

> Since system_clock_scale is a weird thing, I have included
> in the first patch an expansion of the comment describing
> it to be clearer about what it does, and also a TODO note
> sketching out how we could go about eradicating this global.
> 
> thanks
> -- PMM
> 
> Peter Maydell (3):
>   arm: Move system_clock_scale to armv7m_systick.h
>   arm: Remove unnecessary includes of hw/arm/arm.h
>   arm: Rename hw/arm/arm.h to hw/arm/boot.h

Series:

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Tested-by: Philippe Mathieu-Daudé <philmd@redhat.com>