[Qemu-devel] [PATCH v4 0/5] Create setup/cleanup methods for migration incoming side

Juan Quintela posted 5 patches 6 years, 9 months ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20170628095228.4661-1-quintela@redhat.com
Test FreeBSD passed
Test checkpatch passed
Test docker passed
Test s390x passed
hw/ppc/spapr.c               |  6 ++---
include/migration/register.h |  6 +++--
migration/block.c            |  4 +--
migration/colo.c             |  2 +-
migration/migration.c        | 10 +------
migration/ram.c              | 63 +++++++++++++++++++++++++++++++-------------
migration/ram.h              |  6 -----
migration/savevm.c           | 61 +++++++++++++++++++++++++++++++++++-------
migration/savevm.h           |  3 ++-
migration/trace-events       |  4 ++-
10 files changed, 113 insertions(+), 52 deletions(-)
[Qemu-devel] [PATCH v4 0/5] Create setup/cleanup methods for migration incoming side
Posted by Juan Quintela 6 years, 9 months ago
Hi

Changes from v4:
- make sure that we call save_cleanup() in postocpy (dave).

Please, review.

[v3]
- rename htab_cleanup htab_save_cleanup (dave)
- loaded_data was needed because caller can need it (dave)
- improve error message (dave)

Please, review.

[v2]
- Kevin detected that I didn't  called load_cleanup(), fix it.
- Be consistent and change the naming of the functions so they are all:
  qemu_savevm_state_* or qemu_loadvm_state*
- the traces still used the all names of _begin, instead of _setup,
  fix that.

Please, review.

Later, Juan.

PD: Yes, now that the includes are internal, we coauld rename
    "qemu_savevm_state_" to something shorter, like `savevm_".  The
    same for the loadvm counterparts.  But I am not doing any such
    changes soon, too much churn for so little gain.

[v1]
This series make:
- use of cleanup/save methods generic, not only for save_live methods
- create the equivalent methods for the load side (load_setup/cleanup)
- Make ram use this methods to see how/when they are used.

Stefan, Kevin, this were the methods that you asked for the block.c
migration, right?  Please, comment if they are enough for you.

Juan Quintela (5):
  migration: Rename save_live_setup() to save_setup()
  migration: Rename cleanup() to save_cleanup()
  migration: Create load_setup()/cleanup() methods
  migration: Convert ram to use new load_setup()/load_cleanup()
  migration: Make compression_threads use save/load_setup/cleanup()

 hw/ppc/spapr.c               |  6 ++---
 include/migration/register.h |  6 +++--
 migration/block.c            |  4 +--
 migration/colo.c             |  2 +-
 migration/migration.c        | 10 +------
 migration/ram.c              | 63 +++++++++++++++++++++++++++++++-------------
 migration/ram.h              |  6 -----
 migration/savevm.c           | 61 +++++++++++++++++++++++++++++++++++-------
 migration/savevm.h           |  3 ++-
 migration/trace-events       |  4 ++-
 10 files changed, 113 insertions(+), 52 deletions(-)

-- 
2.9.4


Re: [Qemu-devel] [PATCH v4 0/5] Create setup/cleanup methods for migration incoming side
Posted by Dr. David Alan Gilbert 6 years, 9 months ago
* Juan Quintela (quintela@redhat.com) wrote:
> Hi

Queued.

> Changes from v4:
> - make sure that we call save_cleanup() in postocpy (dave).
> 
> Please, review.
> 
> [v3]
> - rename htab_cleanup htab_save_cleanup (dave)
> - loaded_data was needed because caller can need it (dave)
> - improve error message (dave)
> 
> Please, review.
> 
> [v2]
> - Kevin detected that I didn't  called load_cleanup(), fix it.
> - Be consistent and change the naming of the functions so they are all:
>   qemu_savevm_state_* or qemu_loadvm_state*
> - the traces still used the all names of _begin, instead of _setup,
>   fix that.
> 
> Please, review.
> 
> Later, Juan.
> 
> PD: Yes, now that the includes are internal, we coauld rename
>     "qemu_savevm_state_" to something shorter, like `savevm_".  The
>     same for the loadvm counterparts.  But I am not doing any such
>     changes soon, too much churn for so little gain.
> 
> [v1]
> This series make:
> - use of cleanup/save methods generic, not only for save_live methods
> - create the equivalent methods for the load side (load_setup/cleanup)
> - Make ram use this methods to see how/when they are used.
> 
> Stefan, Kevin, this were the methods that you asked for the block.c
> migration, right?  Please, comment if they are enough for you.
> 
> Juan Quintela (5):
>   migration: Rename save_live_setup() to save_setup()
>   migration: Rename cleanup() to save_cleanup()
>   migration: Create load_setup()/cleanup() methods
>   migration: Convert ram to use new load_setup()/load_cleanup()
>   migration: Make compression_threads use save/load_setup/cleanup()
> 
>  hw/ppc/spapr.c               |  6 ++---
>  include/migration/register.h |  6 +++--
>  migration/block.c            |  4 +--
>  migration/colo.c             |  2 +-
>  migration/migration.c        | 10 +------
>  migration/ram.c              | 63 +++++++++++++++++++++++++++++++-------------
>  migration/ram.h              |  6 -----
>  migration/savevm.c           | 61 +++++++++++++++++++++++++++++++++++-------
>  migration/savevm.h           |  3 ++-
>  migration/trace-events       |  4 ++-
>  10 files changed, 113 insertions(+), 52 deletions(-)
> 
> -- 
> 2.9.4
> 
> 
--
Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK