[Qemu-devel] [PATCH] Print a warning message if the user specified a legacy USB option

Thomas Huth posted 1 patch 102 weeks ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/1493711597-21803-1-git-send-email-thuth@redhat.com
Test docker passed
Test s390x passed
vl.c | 4 ++++
1 file changed, 4 insertions(+)

[Qemu-devel] [PATCH] Print a warning message if the user specified a legacy USB option

Posted by Thomas Huth 102 weeks ago
'-usb' and '-usbdevice' are considered as deprecated nowadays and
we might want to remove these options in a future version of QEMU.
So print out a warning if they are used and tell the user what to
use instead.

Signed-off-by: Thomas Huth <thuth@redhat.com>
---
 vl.c | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/vl.c b/vl.c
index 42d4bce..0023298 100644
--- a/vl.c
+++ b/vl.c
@@ -3748,10 +3748,14 @@ int main(int argc, char **argv, char **envp)
                 }
                 break;
             case QEMU_OPTION_usb:
+                error_report("'-usb' is deprecated, please use "
+                             "'-M usb=on' instead");
                 olist = qemu_find_opts("machine");
                 qemu_opts_parse_noisily(olist, "usb=on", false);
                 break;
             case QEMU_OPTION_usbdevice:
+                error_report("'-usbdevice' is deprecated, please use "
+                             "'-device usb-...' instead");
                 olist = qemu_find_opts("machine");
                 qemu_opts_parse_noisily(olist, "usb=on", false);
                 add_device_config(DEV_USB, optarg);
-- 
1.8.3.1