[libvirt] [PATCH 0/5] tools: Adapt to newer wireshark

Michal Privoznik posted 5 patches 10 weeks ago
Test syntax-check passed
Failed in applying to current master (apply log)
.gitignore                              |   1 -
cfg.mk                                  |   2 +-
libvirt.spec.in                         |  10 +-
m4/virt-wireshark.m4                    |  10 +-
tools/Makefile.am                       |  15 +-
tools/wireshark/src/packet-libvirt.c    | 106 +++++++-----
tools/wireshark/src/packet-libvirt.h    |  93 +----------
tools/wireshark/src/plugin.c            |  86 ++++++++++
tools/wireshark/util/make-dissector-reg | 205 ------------------------
9 files changed, 170 insertions(+), 358 deletions(-)
create mode 100644 tools/wireshark/src/plugin.c
delete mode 100755 tools/wireshark/util/make-dissector-reg

[libvirt] [PATCH 0/5] tools: Adapt to newer wireshark

Posted by Michal Privoznik 10 weeks ago
While implementing some other feature I wanted to use wireshark to debug
a migration issue. Only then I found that our wireshark plugin is no
longer being loaded. Here are the fixes.

Michal Prívozník (5):
  tools: Cleanup packet-libvirt.h
  tools: Keep wireshark plugin registration code in git
  wireshark: Provide registration code for newer wireshark
  m4: Put wireshark plugin into epan/ directory
  tools: Drop support for pre-2.4.0 wireshark

 .gitignore                              |   1 -
 cfg.mk                                  |   2 +-
 libvirt.spec.in                         |  10 +-
 m4/virt-wireshark.m4                    |  10 +-
 tools/Makefile.am                       |  15 +-
 tools/wireshark/src/packet-libvirt.c    | 106 +++++++-----
 tools/wireshark/src/packet-libvirt.h    |  93 +----------
 tools/wireshark/src/plugin.c            |  86 ++++++++++
 tools/wireshark/util/make-dissector-reg | 205 ------------------------
 9 files changed, 170 insertions(+), 358 deletions(-)
 create mode 100644 tools/wireshark/src/plugin.c
 delete mode 100755 tools/wireshark/util/make-dissector-reg

-- 
2.19.2

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Re: [libvirt] [PATCH 0/5] tools: Adapt to newer wireshark

Posted by Ján Tomko 10 weeks ago
On Fri, Feb 08, 2019 at 12:23:23PM +0100, Michal Privoznik wrote:
>While implementing some other feature I wanted to use wireshark to debug
>a migration issue. Only then I found that our wireshark plugin is no
>longer being loaded. Here are the fixes.
>
>Michal Prívozník (5):
>  tools: Cleanup packet-libvirt.h
>  tools: Keep wireshark plugin registration code in git
>  wireshark: Provide registration code for newer wireshark
>  m4: Put wireshark plugin into epan/ directory
>  tools: Drop support for pre-2.4.0 wireshark
>
> .gitignore                              |   1 -
> cfg.mk                                  |   2 +-
> libvirt.spec.in                         |  10 +-
> m4/virt-wireshark.m4                    |  10 +-
> tools/Makefile.am                       |  15 +-
> tools/wireshark/src/packet-libvirt.c    | 106 +++++++-----
> tools/wireshark/src/packet-libvirt.h    |  93 +----------
> tools/wireshark/src/plugin.c            |  86 ++++++++++
> tools/wireshark/util/make-dissector-reg | 205 ------------------------
> 9 files changed, 170 insertions(+), 358 deletions(-)
> create mode 100644 tools/wireshark/src/plugin.c
> delete mode 100755 tools/wireshark/util/make-dissector-reg
>

Reviewed-by: Ján Tomko <jtomko@redhat.com>

Jano
--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list