[PATCH] x86/pv: Rename hypercall_table_t to pv_hypercall_table_t

Andrew Cooper posted 1 patch 2 years, 11 months ago
Failed in applying to current master (apply log)
xen/arch/x86/pv/hypercall.c     | 2 +-
xen/arch/x86/pv/shim.c          | 2 +-
xen/include/asm-x86/hypercall.h | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
[PATCH] x86/pv: Rename hypercall_table_t to pv_hypercall_table_t
Posted by Andrew Cooper 2 years, 11 months ago
The type is no longer appropriate for anything other than PV, and therefore
should not retain its generic name.

Fixes: 527922008bc ("x86: slim down hypercall handling when !PV32")
Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
CC: Jan Beulich <JBeulich@suse.com>
CC: Roger Pau Monné <roger.pau@citrix.com>
CC: Wei Liu <wl@xen.org>
---
 xen/arch/x86/pv/hypercall.c     | 2 +-
 xen/arch/x86/pv/shim.c          | 2 +-
 xen/include/asm-x86/hypercall.h | 4 ++--
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/xen/arch/x86/pv/hypercall.c b/xen/arch/x86/pv/hypercall.c
index 5d02eebc8d..e30c59b628 100644
--- a/xen/arch/x86/pv/hypercall.c
+++ b/xen/arch/x86/pv/hypercall.c
@@ -40,7 +40,7 @@
 
 #define do_arch_1             paging_domctl_continuation
 
-const hypercall_table_t pv_hypercall_table[] = {
+const pv_hypercall_table_t pv_hypercall_table[] = {
     COMPAT_CALL(set_trap_table),
     HYPERCALL(mmu_update),
     COMPAT_CALL(set_gdt),
diff --git a/xen/arch/x86/pv/shim.c b/xen/arch/x86/pv/shim.c
index 92cb1adeed..62201ae182 100644
--- a/xen/arch/x86/pv/shim.c
+++ b/xen/arch/x86/pv/shim.c
@@ -204,7 +204,7 @@ void __init pv_shim_setup_dom(struct domain *d, l4_pgentry_t *l4start,
                               unsigned long console_va, unsigned long vphysmap,
                               start_info_t *si)
 {
-    hypercall_table_t *rw_pv_hypercall_table;
+    pv_hypercall_table_t *rw_pv_hypercall_table;
     uint64_t param = 0;
     long rc;
 
diff --git a/xen/include/asm-x86/hypercall.h b/xen/include/asm-x86/hypercall.h
index 39e7ab7022..0ae3b8b043 100644
--- a/xen/include/asm-x86/hypercall.h
+++ b/xen/include/asm-x86/hypercall.h
@@ -20,7 +20,7 @@ typedef struct {
 #ifdef CONFIG_PV32
     hypercall_fn_t *compat;
 #endif
-} hypercall_table_t;
+} pv_hypercall_table_t;
 
 typedef struct {
     uint8_t native;
@@ -32,7 +32,7 @@ typedef struct {
 extern const hypercall_args_t hypercall_args_table[NR_hypercalls];
 
 #ifdef CONFIG_PV
-extern const hypercall_table_t pv_hypercall_table[];
+extern const pv_hypercall_table_t pv_hypercall_table[];
 void pv_hypercall(struct cpu_user_regs *regs);
 #endif
 
-- 
2.11.0


Re: [PATCH] x86/pv: Rename hypercall_table_t to pv_hypercall_table_t
Posted by Jan Beulich 2 years, 11 months ago
On 15.04.2021 15:21, Andrew Cooper wrote:
> The type is no longer appropriate for anything other than PV, and therefore
> should not retain its generic name.
> 
> Fixes: 527922008bc ("x86: slim down hypercall handling when !PV32")
> Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>

I'm not convinced this warrants a Fixes: tag (afaict there's no breakage),
but in any event
Reviewed-by: Jan Beulich <jbeulich@suse.com>
I had considered doing the rename at the same time, but then decided to
save on the extra code churn. I'm sorry if this was the wrong choice.

Jan

Re: [PATCH] x86/pv: Rename hypercall_table_t to pv_hypercall_table_t
Posted by Andrew Cooper 2 years, 11 months ago
On 15/04/2021 15:04, Jan Beulich wrote:
> On 15.04.2021 15:21, Andrew Cooper wrote:
>> The type is no longer appropriate for anything other than PV, and therefore
>> should not retain its generic name.
>>
>> Fixes: 527922008bc ("x86: slim down hypercall handling when !PV32")
>> Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
> I'm not convinced this warrants a Fixes: tag (afaict there's no breakage),
> but in any event
> Reviewed-by: Jan Beulich <jbeulich@suse.com>
> I had considered doing the rename at the same time, but then decided to
> save on the extra code churn. I'm sorry if this was the wrong choice.

I would have requested the change on code review.  Not necessarily part
of that patch, if it were easier to split out into an adjacent change,
but the patch did fundamentally change the purpose of the type.

Part of me still wonders whether it would be better to drop the type
entirely, as on the HVM side.  However, whichever way you rewrite this,
you've always got an ugly plumbing problem with the pvshim alterations.

~Andrew