[PATCH v2 0/2] hw: Replace some impossible checks by assertions

Philippe Mathieu-Daudé posted 2 patches 3 years, 6 months ago
Test docker-quick@centos7 failed
Test docker-mingw@fedora failed
Test checkpatch failed
Test FreeBSD failed
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/qemu tags/patchew/20200910072325.439344-1-f4bug@amsat.org
hw/gpio/max7310.c   | 5 +----
hw/ppc/ppc4xx_pci.c | 2 +-
2 files changed, 2 insertions(+), 5 deletions(-)
[PATCH v2 0/2] hw: Replace some impossible checks by assertions
Posted by Philippe Mathieu-Daudé 3 years, 6 months ago
Trivial patches removing unreachable code.

Since v1:
- dropped patches queued
- replace dead code by assert (Peter)
- use PCI_NUM_PINS definition (Cédric)

Philippe Mathieu-Daudé (2):
  hw/gpio/max7310: Remove impossible check
  hw/ppc/ppc4xx_pci: Replace magic value by the PCI_NUM_PINS definition

 hw/gpio/max7310.c   | 5 +----
 hw/ppc/ppc4xx_pci.c | 2 +-
 2 files changed, 2 insertions(+), 5 deletions(-)

-- 
2.26.2

Re: [PATCH v2 0/2] hw: Replace some impossible checks by assertions
Posted by Richard Henderson 3 years, 6 months ago
On 9/10/20 12:23 AM, Philippe Mathieu-Daudé wrote:
> Trivial patches removing unreachable code.
> 
> Since v1:
> - dropped patches queued
> - replace dead code by assert (Peter)
> - use PCI_NUM_PINS definition (Cédric)
> 
> Philippe Mathieu-Daudé (2):
>   hw/gpio/max7310: Remove impossible check
>   hw/ppc/ppc4xx_pci: Replace magic value by the PCI_NUM_PINS definition
> 
>  hw/gpio/max7310.c   | 5 +----
>  hw/ppc/ppc4xx_pci.c | 2 +-
>  2 files changed, 2 insertions(+), 5 deletions(-)
> 

Reviewed-by: Richard Henderson <richard.henderson@linaro.org>


r~