[SeaBIOS] [PATCH 0/2] Minor vgabios comment and variable name changes

Kevin O'Connor posted 2 patches 1 month, 2 weeks ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/seabios tags/patchew/20240316000129.4099892-1-kevin@koconnor.net
vgasrc/bochsvga.c    | 40 ++++++++++----------
vgasrc/bochsvga.h    | 16 ++++----
vgasrc/cbvga.c       | 30 +++++++--------
vgasrc/clext.c       | 20 +++++-----
vgasrc/stdvga.c      | 40 +++++++++++---------
vgasrc/stdvga.h      | 17 +++++----
vgasrc/stdvgamodes.c | 12 +++---
vgasrc/swcursor.c    | 16 ++++----
vgasrc/vbe.c         | 53 +++++++++++++-------------
vgasrc/vgabios.c     |  6 +--
vgasrc/vgafb.c       | 88 ++++++++++++++++++++++----------------------
vgasrc/vgafb.h       |  4 +-
vgasrc/vgahw.h       | 88 ++++++++++++++++++++++----------------------
vgasrc/vgautil.h     | 31 ++++++++--------
14 files changed, 233 insertions(+), 228 deletions(-)
[SeaBIOS] [PATCH 0/2] Minor vgabios comment and variable name changes
Posted by Kevin O'Connor 1 month, 2 weeks ago
These two patches are name and comment changes only.  The goal is to
make the vgahw_xxx() functions a little more clear.

The current vga mode description struct (struct vgamode_s) is passed
around to avoid extra calls to get_current_mode().  However, this can
be confusing as some vgahw_xxx() calls work on an arbitrary mode while
others only work on the current video mode.  Use separate names
(curmode_g vs vmode_g) to make the distinction more clear.

-Kevin



Kevin O'Connor (2):
  vgasrc: Use curmode_g instead of vmode_g when mode is the current
    video mode
  vgasrc: Rename vgahw_get_linesize() to vgahw_minimum_linelength()

 vgasrc/bochsvga.c    | 40 ++++++++++----------
 vgasrc/bochsvga.h    | 16 ++++----
 vgasrc/cbvga.c       | 30 +++++++--------
 vgasrc/clext.c       | 20 +++++-----
 vgasrc/stdvga.c      | 40 +++++++++++---------
 vgasrc/stdvga.h      | 17 +++++----
 vgasrc/stdvgamodes.c | 12 +++---
 vgasrc/swcursor.c    | 16 ++++----
 vgasrc/vbe.c         | 53 +++++++++++++-------------
 vgasrc/vgabios.c     |  6 +--
 vgasrc/vgafb.c       | 88 ++++++++++++++++++++++----------------------
 vgasrc/vgafb.h       |  4 +-
 vgasrc/vgahw.h       | 88 ++++++++++++++++++++++----------------------
 vgasrc/vgautil.h     | 31 ++++++++--------
 14 files changed, 233 insertions(+), 228 deletions(-)

-- 
2.44.0

_______________________________________________
SeaBIOS mailing list -- seabios@seabios.org
To unsubscribe send an email to seabios-leave@seabios.org
[SeaBIOS] Re: [PATCH 0/2] Minor vgabios comment and variable name changes
Posted by Kevin O'Connor 1 month, 1 week ago
On Fri, Mar 15, 2024 at 07:57:46PM -0400, Kevin O'Connor wrote:
> These two patches are name and comment changes only.  The goal is to
> make the vgahw_xxx() functions a little more clear.
> 
> The current vga mode description struct (struct vgamode_s) is passed
> around to avoid extra calls to get_current_mode().  However, this can
> be confusing as some vgahw_xxx() calls work on an arbitrary mode while
> others only work on the current video mode.  Use separate names
> (curmode_g vs vmode_g) to make the distinction more clear.
> 

I committed this change.

-Kevin
_______________________________________________
SeaBIOS mailing list -- seabios@seabios.org
To unsubscribe send an email to seabios-leave@seabios.org