[libvirt] [PATCH 0/5] Split out network object into its own module

John Ferlan posted 5 patches 7 years, 1 month ago
Patches applied successfully (tree, apply log)
git fetch https://github.com/patchew-project/libvirt tags/patchew/20170318132650.2390-1-jferlan@redhat.com
po/POTFILES.in                       |    1 +
src/Makefile.am                      |    3 +-
src/conf/network_conf.c              | 1387 ++--------------------------------
src/conf/network_conf.h              |  204 ++---
src/conf/virnetworkobj.c             | 1371 +++++++++++++++++++++++++++++++++
src/conf/virnetworkobj.h             |  185 +++++
src/libvirt_private.syms             |   57 +-
src/network/bridge_driver.c          |   62 +-
src/network/bridge_driver.h          |    2 +-
src/network/bridge_driver_platform.h |    2 +-
src/test/test_driver.c               |   16 +-
11 files changed, 1762 insertions(+), 1528 deletions(-)
create mode 100644 src/conf/virnetworkobj.c
create mode 100644 src/conf/virnetworkobj.h
[libvirt] [PATCH 0/5] Split out network object into its own module
Posted by John Ferlan 7 years, 1 month ago
Reached the last of the code from my RFC for making a common pool
object - networkobj...  For reference see patch 3 of:

http://www.redhat.com/archives/libvir-list/2017-February/msg00519.html

This series works through the network conf adjustments. This pile is
fairly straightforward, like other series we split out anything referencing
virNetworkPoolObj and go from there. There was one small detour to avoid
a potentially conflict in names.

John Ferlan (5):
  conf: Introduce virnetworkobj
  conf: Adjust coding style for network conf sources
  conf: Alter coding style of network conf function prototypes
  conf: Rename virNetworkObjAssignDef to virNetworkObjUpdateAssignDef
  conf: Use consistent function name prefixes for virnetworkobj

 po/POTFILES.in                       |    1 +
 src/Makefile.am                      |    3 +-
 src/conf/network_conf.c              | 1387 ++--------------------------------
 src/conf/network_conf.h              |  204 ++---
 src/conf/virnetworkobj.c             | 1371 +++++++++++++++++++++++++++++++++
 src/conf/virnetworkobj.h             |  185 +++++
 src/libvirt_private.syms             |   57 +-
 src/network/bridge_driver.c          |   62 +-
 src/network/bridge_driver.h          |    2 +-
 src/network/bridge_driver_platform.h |    2 +-
 src/test/test_driver.c               |   16 +-
 11 files changed, 1762 insertions(+), 1528 deletions(-)
 create mode 100644 src/conf/virnetworkobj.c
 create mode 100644 src/conf/virnetworkobj.h

-- 
2.9.3

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list
Re: [libvirt] [PATCH 0/5] Split out network object into its own module
Posted by John Ferlan 7 years ago

ping?

Laine only had a question about the altered format for network_conf.h
files.  I don't think there's been enough change to cause any merge
conflicts with top of tree, but I can repost if necessary.

I have a few more ready to roll as well in the continuing effort to make
a common driver object model. I'm into the object code now and would
like to be sure the "names" I choose are well received before I get too
far ahead and need to change everything.

Tks -

John

On 03/18/2017 09:26 AM, John Ferlan wrote:
> Reached the last of the code from my RFC for making a common pool
> object - networkobj...  For reference see patch 3 of:
> 
> http://www.redhat.com/archives/libvir-list/2017-February/msg00519.html
> 
> This series works through the network conf adjustments. This pile is
> fairly straightforward, like other series we split out anything referencing
> virNetworkPoolObj and go from there. There was one small detour to avoid
> a potentially conflict in names.
> 
> John Ferlan (5):
>   conf: Introduce virnetworkobj
>   conf: Adjust coding style for network conf sources
>   conf: Alter coding style of network conf function prototypes
>   conf: Rename virNetworkObjAssignDef to virNetworkObjUpdateAssignDef
>   conf: Use consistent function name prefixes for virnetworkobj
> 
>  po/POTFILES.in                       |    1 +
>  src/Makefile.am                      |    3 +-
>  src/conf/network_conf.c              | 1387 ++--------------------------------
>  src/conf/network_conf.h              |  204 ++---
>  src/conf/virnetworkobj.c             | 1371 +++++++++++++++++++++++++++++++++
>  src/conf/virnetworkobj.h             |  185 +++++
>  src/libvirt_private.syms             |   57 +-
>  src/network/bridge_driver.c          |   62 +-
>  src/network/bridge_driver.h          |    2 +-
>  src/network/bridge_driver_platform.h |    2 +-
>  src/test/test_driver.c               |   16 +-
>  11 files changed, 1762 insertions(+), 1528 deletions(-)
>  create mode 100644 src/conf/virnetworkobj.c
>  create mode 100644 src/conf/virnetworkobj.h
> 

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list